Eleksmaker A3 Pro – Setup with Lightburn

Home Forums Help and How To Machine Setup/Troubleshooting Eleksmaker A3 Pro – Setup with Lightburn

This topic contains 2 replies, has 2 voices, and was last updated by  LightBurn 9 months ago.

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #2938

    dekbox
    Participant

    I am having trouble getting my Eleksmaker A3 Pro laser to correspond with the work area in Lightburn. I think it’s because the machine hasn’t been ‘Homed’. When I manually move the lazer to my desired home position and click the Home button get an error saying ‘error: Setting disabled’. I can’t seen to find where to enable this setting. It seems that the work area isn’t set up correctly at all but I can’t seem to figure out what I’ve done wrong.  I’ve been at it for 2 days now and starting to lose my mind a bit! haha. Any help would be greatly appreciated!

    #2946

    LightBurn
    Participant

    The “Home” button in LightBurn runs the homing cycle on the controller, which seeks the limit switches to zero itself.  If you run LightBurn in “Current Position” mode, it will just run the job from wherever the laser is positioned.  You likely don’t have limit / homing switches installed on the A3, so the home button will simply cause GRBL to return an error.

    https://github.com/LightBurnSoftware/Documentation/blob/master/CoordinatesOrigin.md

    #2948

    LightBurn
    Participant

    You should also power up the laser with the head positioned to the origin (front left) as that will allow you to use the other modes in LightBurn too.

Viewing 3 posts - 1 through 3 (of 3 total)

You must be logged in to reply to this topic.